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1 OVERVIEW 

The NuEclipse is designed for cross-platform embedded MCU development. It includes a series of 
Eclipse plug-ins and tools. The plug-ins allow the user to create, build, and debug ARM-based and 
NuMicro 8051 1T projects within the Eclipse framework. Its features are listed below: 

⚫ Creating projects by the New Project Wizard: The New Project Wizard provides several 
templates for different target chips. 

⚫ Building projects by the GNU ARM Toolchain: The toolchain contains the ARM Embedded 
GCC compiler. The user can use it to build projects without restriction. 

⚫ Debugging projects by GDB: The user can halt, step, run, and monitor target chips. 
Accessing memory and flash is allowed. Setting hardware breakpoints and watchpoints is 
supported. In addition, the user can erase target chips and program the user configuration. 

Through the NuEclipse, the user can develop projects of the NuMicro®  Family within the Eclipse 
framework. 

 Supported Chips 

To see the list of supported chips, please refer to Supported_chips.htm in the folder of user manual. 
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2 REQUIREMENTS 

The following table lists system requirements for the user to run the NuEclipse. 

 Minimum Requirements Recommended Specifications 

Operating System Windows® 7 x64 or GNU/Linux Windows® 10 x64 or Ubuntu 18.04 LTS 

GNU ARM Embedded Toolchain 10.3-2021.10 The latest version 

Note: To have a fully usable and pleasant experience on Linux, the recommended Linux distribution is 
Ubuntu 18.04 LTS (64-bit).  
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3 QUICK START 

 Installation 

To make the NuEclipse ready for work, perform the following steps based on your operating system: 

1. Performing the NuEclipse installer on Microsoft Windows. 

2. Extracting the NuEclipse tar file on GNU/Linux. 

3.1.1 Performing the NuEclipse Installer on Microsoft Windows 

On Windows, it is very easy to install the NuEclipse only by performing the NuEclipse installer. The 
installer will ask the user to install the GNU ARM Eclipse Windows Build Tools and GNU ARM 
Embedded Toolchain because they are required by NuEclipse. 

 

Figure 3-1 NuEclipse Setup Wizard 
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3.1.2 Extracting the NuEclipse Tar File on GNU/Linux 

On GNU/Linux, it is very easy to install the NuEclipse only by extracting the NuEclipse tar file. After that, 
run the install.sh script to complete the installation process. Please do not use the sudo command to 
run the script. 

 

Figure 3-2 Install.sh Script 

. 
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3.1.3 Verifying the Eclipse Preferences 

After the installation, the Eclipse preferences are automatically written on Windows. To verify them, click 
Window > Preferences, the Preferences wizard appears. Go to C/C++ > Build > Global Tools Paths 
and make sure the Build tools and Toolchain folder be correctly configured to what the installer has 
installed in the previous step. Click the Apply button to take effect. On GNU/Linux, Build tools folder 
path is not required. The path should be empty. 

 

Figure 3-3 Preferences for Global Tools Paths 
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Subsequently, go to Run/Debug > OpenOCD Nu-Link and make sure the OpenOCD folder be 
configured to where the installer has put the OpenOCD executable. On Microsoft Windows, for example, 
the path of OpenOCD folder could be C:/Program Files (x86)/Nuvoton Tools/OpenOCD. Similarly, on 
GNU/Linux it could be /usr/local/OpenOCD. The OpenOCD executable provided by Nuvoton is 
customized for Nu-Link. If the user tries to use other OpenOCD executable, OpenOCD and Nu-Link may 
not cooperate well. Click the Apply button to take effect. 

 

Figure 3-4 Preferences for OpenOCD Nu-Link 
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 Running Eclipse 

To run NuEclipse, double-click the eclipse.exe. Note that the .exe file and the related folders, such as 
the OpenOCD folder, should stay in the same directory; otherwise, the application will not work properly. 

 

Figure 3-5 Eclipse.exe and Related Folders 

 



NuEclipse 

Jun. 14, 2024 Page 13 of 62 Rev 1.02.027 

N
U

E
C

L
IP

S
E

 U
S

E
R

 M
A

N
U

A
L

 

4 DEVELOPMENT TUTORIAL 

 Select Workspace 

When Eclipse launches, we have to select a workspace which groups a set of related projects together 
that usually make up an application. In addition, some configuration settings for Eclipse and projects are 
stored here, too. For different computers, the configuration settings may change. We should create our 
own workspace rather than copying another user’s workspace. Only one workspace can be active at 
one time. The current workspace for Eclipse can be switched by clicking File->Switch Workspace. 

 

Figure 4-1 Selecting a Workspace 

  



NuEclipse 

Jun. 14, 2024 Page 14 of 62 Rev 1.02.027 

N
U

E
C

L
IP

S
E

 U
S

E
R

 M
A

N
U

A
L

 

 New Project Wizard 

As a beginner, the fastest way to create a C/C++ project is using the New Project Wizard. For instance, 
to create a C project, click File > New > C Project. The New Project Wizard appears. Here we choose 
Hello World Nuvoton Cortex-M C Project for Project type. Input the project name and click the Next 
> button to continue. 

 

Figure 4-2 New Project Wizard 
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Based on the actual target chip, we select the corresponding chip series. For some chip series, e.g., 
M2351_NonSecure, we need to input the additional library path. If not, the build process may fail. In 
addition, input the real values to Flash and RAM size. If not, the default values will be used. When all 
the settings are done, click the Next > buttons until clicking the Finish button. 

 

Figure 4-3 Target Processor Settings 
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 Import Existing Projects 

When BSP projects are available, we can import them into the workspace using the following steps: 

1. From the main menu bar, select File > Import. The Import wizard shows up. 

2. Select General > Existing Project into Workspace and click Next. 

3. Choose either Select root directory or Select archive file and click the 
associated Browse to locate the directory or file containing the projects. In the Nuvoton BSP, the 
Eclipse projects are stored in the GCC folder. 

4. Under Projects select the project or projects which you would like to import and click Finish. 

 

Figure 4-4 Importing Projects 
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 Build Settings 

After projects have been created, we still have a chance to alter the build settings by clicking Project > 
Properties. The Properties wizard shows up. Then go to C/C++ Build > Settings. From there, we can 
alter the build settings according to the actual target chip. Then click the Apply button to take effect. 
After applying build settings, we should be able to build projects successfully. 

 

Figure 4-5 Build Settings 
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 Debug Configuration 

Before launching an application into the debug mode, we have to prepare a debug configuration, which 
contains all the necessary information about the debug mode. Click Run > Debug Configuration… to 
open the debug configuration dialog. Double click on the GDB Nuvoton Nu-Link Debugging group. 
The Nuvoton Nu-Link debug configuration appears on the right-hand side. In the Main tab, the name of 
Project should coincide with the project name. The C/C++ Application should point to the elf application 
generated by the build process. If the project name or C/C++ Application is incorrect, please select the 
expected project first in the project view, build the project to generate the executable, and expand the 
tree to make sure the existence of the generated executable. Then repeat the former operations again. 

 

Figure 4-6 Debug Configuration 
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4.5.1 Debugger Tab 

The Debugger tab is used to provide the OpenOCD and GDB Client setup. OpenOCD requires correct 
configuration files to know how to work with adapters and target chips. The configuration files are 
specified in the Config options field. Nuvoton’s adapter is Nu-Link, which uses the interface 
configuration file named nulink.cfg. In addition, Nuvoton has three different ARM families, such as M0, 
M4, and M23. The corresponding target configuration files are numicroM0.cfg, numicroM4.cfg, and 
numicroM23.cfg. For M23 2nd development, the target configuration file would be 
numicroM23_NS.cfg. For MA35D1 development, see Section 4.10. 

 

Figure 4-7 Configuring the Debugger Tab 
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4.5.2 Startup Tab 

As the first step, we should choose the right Chip Series in the Startup tab. When done, the 
corresponding target configuration file will be automatically written in the Config options field of the 
Debugger tab.  To load executable to flash, we need to select the Load executable to flash checkbox. 
To load executable to RAM, we need to select the Load executable to SRAM checkbox. When all the 
settings are done, click the Apply button to take effect. To launch the application into the debug mode, 
click the Debug button. 

 

Figure 4-8 Configuring the Startup Tab 
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 Debug Views 

Eclipse provides many debug views. Each of them contains specific information for debugging. 

4.6.1 Registers View 

When entering the debug mode, we can open the Registers view in the bottom of Debug perspective. 
The Registers view lists information about the registers in a selected stack frame. 

 

Figure 4-9 Registers View 
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4.6.2 Memory View 

The Memory view of the Debug perspective is used to monitor and modify the process memory. The 
process memory is presented as a list of so called memory monitors. Each monitor represents a 
section of memory specified by its location called base address. To open it, click the Memory tab on 
the lower side of Debug perspective. 

 

Figure 4-10 Memory View 
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4.6.3 Disassembly View 

The Disassembly view shows the loaded program as assembler instructions mixed with source code for 
comparison. We can do the following tasks in the Disassembly view: 

1. Setting breakpoints at the start of any assembler instruction. 

2. Enabling and disabling breakpoints. 

3. Stepping through the disassembly instructions of the program. 

4. Jumping to specific instructions in the program. 

 

To open it, we need to click the Instruction Stepping Mode button on the upper toolbar, as follows: 

 

Figure 4-11 Clicking the Instruction Stepping Mode Button 

 

Then the Disassembly view will appear on the right-hand side. 

 

Figure 4-12 Disassembly View 
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4.6.4 Peripheral Registers View 

To display the Peripheral Registers view, we need to utilize Packs mechanism. Packs can help the user 
download special function register (SFR) files from the Keil repository. Firstly, we open the Packs 
perspective by choosing it in the Open Perspective dialog. 

 

Figure 4-13 Opening the Packs Perspective 

 

  



NuEclipse 

Jun. 14, 2024 Page 25 of 62 Rev 1.02.027 

N
U

E
C

L
IP

S
E

 U
S

E
R

 M
A

N
U

A
L

 

For the first time we see the Packs perspective, its content is provided by the NuEclipse installer. If the 
default content is missing, please switch to a new workspace and try again. To get the latest version, 
click the Update the packages definitions from all repositories button at the upper-right corner. After 
clicking, Eclipse begins downloading all the SFR files from an online repository. 

 

Figure 4-14 How to Download Packages 
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The locations of repositories are specified in the Window > Preferences > C/C++ > Packages > 
Repositories. The default is from Keil’s CMSIS Pack. 

 

Figure 4-15 Locations of Repositories 
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When the download is completed, we can find the Nuvoton SFR files and install them on Eclipse if 
needed. 

 

Figure 4-16 Installing SFR Files 
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To use the specific SFR file, open the project’s properties dialog and go to the C/C++ Build > Settings. 
From there, we should choose the specific device matching the real one. In this case, it is M487JIDAE. 
Click the Apply button to take effect. 

 

Figure 4-17 Device Selection 
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As a result, we can monitor the peripheral registers when debugging. 

 

Figure 4-18 Peripheral Registers View 
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 Watchpoints 

To add watchpoints on Eclipse, we need to do the following steps:  

1. Selecting a globe variable, i.e. g_seconds, in the Outline view. 

2. Right-clicking on the global variable and choosing Toggle Watchpoint. 

 

 

Figure 4-19 Toggle Watchpoint 
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3. Configuring the settings for watchpoints. To stop execution when the watch expression is read, 
select the Read checkbox. To stop execution when the watch expression is written to, select 
the Write checkbox. 

 

Figure 4-20 Properties for C/C++ Watchpoint 

 

When the watchpoint is added, it appears in the Breakpoints view. 

 

Figure 4-21 Added Watchpoint in the Breakpoints View 

 

  



NuEclipse 

Jun. 14, 2024 Page 32 of 62 Rev 1.02.027 

N
U

E
C

L
IP

S
E

 U
S

E
R

 M
A

N
U

A
L

 

 Debug in RAM 

To debug in RAM, there are several steps to follow: 

1. Modifying the ld script. 

2. Assigning PC to the specific RAM address. 

3. Assigning SP to the specific RAM address. 

4. Downloading the binary file to RAM. 

The ld script is responsible for telling the linker the layout of the compiled executable. For example, the 
memory layout looks like:  

 

 

Figure 4-22 Memory Layout 
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The modified ld script should meet the memory layout design. 

 

Figure 4-23 Modifying the ld Script 
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To assign PC and SP to the specific addresses, we need to input them in the debug configuration, as 
follows. Based on the previous memory layout, the PC and SP addresses should be Reset_Handler and 

0x20001400, respectively. In addition, set Vector Table Offset Register (0xE000ED08) should be 
0x20000000 and unselect the Pre-run/Restart reset Button. To download the binary to RAM, we select 
the Load executable to SRAM button and unselect the Load executable to flash button. Click the 
Debug button to start a debug session. 

 

Figure 4-24 Debug Configuration Settings 
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When the program stops in the main function, we open the Memory view. From there, we can verify that 
the binary file is successfully downloaded into RAM. The first word denotes the SP address. The 
following words denote the addresses of handlers. 

 

Figure 4-25 Debugging in RAM 
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 Debug Executable Files Only 

If the user has an executable built with debug symbols but may not have the relevant environment used 
to build the executable, he still is able to debug the executable by the following steps: 

1. Import an executable for debugging (referring to Figure 4-26). 

2. Click Browse following Select executable, then select an executable (referring to Figure 4-27).  

3. Choose GDB Nuvoton Nu-Link Debugging as a Launch Configuration (referring to Figure 
4-28). 

4. Locate the GDB executable in the debug configuration (referring to Figure 4-29). 

5. Choose the ELF file to download in the debug configuration (referring to Figure 4-30). 

6. Add source lookup path relative to source folders (referring to Figure 4-31). 

7. Press on the Debug button. 

 

Figure 4-26 Importing Executable for Debugging 
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Figure 4-27 Selecting Executable 
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Figure 4-28 Choosing GDB Nuvoton Nu-Link Debugging 

 



NuEclipse 

Jun. 14, 2024 Page 39 of 62 Rev 1.02.027 

N
U

E
C

L
IP

S
E

 U
S

E
R

 M
A

N
U

A
L

 

 

Figure 4-29 Locating the GDB Executable 
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Figure 4-30 Choosing the ELF File to Download 
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Figure 4-31 Adding Source Lookup Path 
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 Configuration of Cortex-A, Multi-core SMP and AMP system 

4.10.1 Preliminary Preparation 

Suggest using Nu-Link2 family as debugger, and being sure to upgrade Nu-Link2 firmware version 
higher than v3.09.7380r. 

The term SMP stands for symmetric mulitiprocessing, AMP is asymmetric mulitiprocessing. 

Nu-Link2 had built-in CMSIS-DAP interface from v3.09.7380r, and this CMSIS-DAP interface is used to 
support Single Cortex-A, Multi-Core SMP and AMP (Cortex-A + Cortex-M). 

Besides, NuEclipse provides GNU toolchain for the Cortex-A family which resides in NuEclipse/Others 
folder. After configuring this toolchain (see Section 3.1.3), we can build MA35D1’s projects. 
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4.10.2 Configuration of debugging Single-core Cortex-A 

This section describes how to configure a single Cortex-A core debug. 

Take Nuvoton MA35D1 as an example, which has dual Arm Cortex-A35 cores and one Arm Cortex-M4 
core. To debug it, we should choose NuMicro A35 and resume the target at the position where the 
executable starts running in the Startup tab, as follows. For more details, please refer to Section 4.5. To 

download other images, the command would be: monitor load_image filename address. 

To load other script, the command would be: monitor script filename. 

E.g. load DDR initial script, as follows. 

 

 

Figure 4-32 Configuring the Startup Tab for MA35D1 
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When the images are too large, the download command may face a timeout. To avoid that, go to 
Window > Preferences > C/C+ > Debug > GDB and disable the Command timeout or increase it. 

 

Figure 4-33 How to Disable Command Timeout 
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To debug single A35 core, we have to disable CPU1 setting by commenting out the following code in 
the numicroMA35D1.cfg. On Windows, the location where numicroMA35D1.cfg resides could be 
C:\Program Files (x86)\Nuvoton Tools\ OpenOCD\scripts\target. On GNU/Linux, it could be 
/usr/local/OpenOCD/scripts/target.  

 

Figure 4-34 Disable CPU1 Setting 

After choosing NuMicro A35 in the Startup tab, the numicroMA35D1.cfg will be automatically updated 
in the Config options field of the Debugger tab. Because of single-core debugging, the OpenOCD GDB 
port and GDB client port should be the same value, e.g., 3333. When all the settings are done, click the 
Apply button to take effect. To launch the application into the debug mode, click the Debug button. 
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Figure 4-35 Configuring the Debugger Tab for Single-core Debugging on MA35D1 
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4.10.3 Configuration of debugging Dual-core Cortex-A in SMP mode 

To debug SMP, e.g. dual A35 core, please refer to Section 4.10.2, but bypass the step that disabling 
CPU1 setting. 

4.10.4 Configuration of debugging Single-core Cortex-A and Cortex-M in AMP mode 

To debug AMP, e.g. one A35 core and M4 simultaneously, we build the A35 and M4 projects and create 
the corresponding debug configurations (see Section 4.5). The debug configuration of A35 follows 
previous section to complete settings. However, the debug configuration of M4 differs from the Debugger 
Tab. Uncheck the Start OpenOCD locally checkbox. The value of GDB Client port and Remote Target 
port is set to 3334. 

 

Figure 4-36 Configuring the Debugger Tab for Multi-core Debugging on M4 core 
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To launch A35 and M4 applications simultaneously, we use Launch Group by the following steps: 

1. Give a name to the newly created launch group. 

2. Press on the Add button. 

3. Add the expected launch configurations to the launch group. 

4. Press on the OK button. 

5. Move the A35 launch configuration in the first sequence order. 

6. Press on the Apply button to take effect. 

7. Press on the Debug button to run the group launch. 

 

Figure 4-37 Configuring the Launch Group 
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4.10.5 Configuration of debugging Dual-core Cortex-A and Cortex-M in AMP mode 

To debug AMP, e.g. dual A35 core and M4 simultaneously, we have to disable the CPU Symmetric Multi-
Processors (SMP) by commenting out the following code in the numicroMA35D1.cfg. On Windows, the 
location where numicroMA35D1.cfg resides could be C:\Program Files (x86)\Nuvoton Tools\ 
OpenOCD\scripts\target. On GNU/Linux, it could be /usr/local/OpenOCD/scripts/target.  

 

Figure 4-38 How to Disable SMP 

The debug configuration of A35 CPU0 follows Section 4.10.2 to complete settings. The debug 
configuration of A35 CPU1 and M4 follows Section 4.10.3 to complete settings, but the value of GDB 
Client port and Remote Target port differs. That of A35 CPU1 and M4 is 3334 and 3335, respectively. 
The Launch Group should include the launch configurations of A35 CPU0, CPU1 and M4. Make sure 
that the A35 CPU0 launch configuration is in the first sequence order, then press on the Debug button 
to run the group launch. While entering the debug mode, we can switch different CPU core to debug by 
clicking on the corresponding execution of threads in the Debug view. 

 

Figure 4-39 Multi-core Debugging 
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4.10.6 Configuration of debugging Cortex-A Core in AARCH32 mode 

The settings in chapter 4.10 are mostly for ARM v8a AARCH64 mode by default. In this section, we 
describe how to debug a AARCH32 application. 

For example, to debug AARCH32 program on Cortex-A35, we first enter debug mode to run AARCH64 
code and leave debug mode. And then re-enter debug mode switching to AARCH32 code for debugging. 
We import executable files (see Section 4.9) and create the corresponding debug configurations (see 
Section 4.5). On Windows, the location where numicroMA35D1.cfg resides could be  

C:\Program Files (x86)\Nuvoton Tools\OpenOCD\scripts\target. On GNU/Linux, it could be 
/usr/local/OpenOCD/scripts/target. There are several steps to follow: 

1. Import an executable for debugging (referring to Figure 4-26). 

2. Click browse following select executable, then select an executable (referring to Figure 4-27).  

3. Choose GDB Nuvoton Nu-Link Debugging as a Launch Configuration (referring to Figure 
4-28). 

4. Locate the GDB executable in the debug configuration (referring to Figure 4-40). 

5. Choose the ELF file to download and initial setting in the debug configuration (referring to 
Figure 4-41). Please based on DDR of dev-board to select the corresponding DDR initial file. 

6. These files could be found in C:\Program Files (x86)\Nuvoton Tools\OpenOCD\scripts\board 
folder.  

7. (monitor Script ../scripts/board/numicroMA35D1_DDR3_256MB_1066MBPS_WINBOND.cfg) 

8. Press on the Debug button. 

9. Set breakpoint at the last address of aarch64 program and resume to the address. 

10. Press run button and then leave debug mode. 

11. Uncheck the reset settings and re-enter debug mode (referring to Figure 4-42). 

12. Debug AARCH32 program (referring to Figure 4-43). 

 

The above description is for debugging AARCH32 program in dual core SMP mode. AARCH32 program 
debugging can also be used in the following two settings 

1. Refer to Figure 4-34 to disable CPU1 setting for single core mode. 

2. Refer to Figure 4-38 to disable the CPU SMP for AMP mode. 
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Figure 4-40 Locating the AARCH64 GDB Executable 

 

 

Figure 4-41 The First Time to Enter the Debug Mode Settings 
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Figure 4-42 The Second Time to Enter the Debug Mode Settings 

 

 

Figure 4-43 AARCH32 Program Debugging  
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 Configuration of NuMicro 8051 1T 

Please download NuEclipse_Windows (For NuMicro 8051) from Nuvoton website. 

4.11.1 Import and Build Project 

When NuMicro 8051 1T BSP projects are available, we can import them into the workspace. For more 
details, please refer to Section 4.3.  

Refer to Section 4.4 to build project. After building project successfully, Console View would show 
checksum information and generate bin file. 

 

Figure 4-44 Build NuMicro 8051 1T project 

4.11.2 Debug Configuration 

This section describes how to configure NuMicro 8051 1T debugging. 

In debugger tab, the configuration files are numicro8051_1T.cfg in the Config options field. The install 
path of gdb.exe must be set in GDB Client Setup Executable field. Refer to Figure 4-45. 
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Figure 4-45 NuMicro 8051 1T Debug Configuration in Debugger Tab 

4.11.3 Monitor different Memory Space 

NuEclipse provides different 8051 memory space access. Variables may be explicitly assigned to a 
specific memory space (by including a memory space specifier in the declaration) or implicitly assigned 
(based on the memory model). 

According to different memory space, the corresponding offset position must be specified in order to 
access specific memory space data. Please refer to the table below. 

Memory space of SDCC declaration Data access address 

__code (CODE address) + 0 

__data (DATA address) + 0xF0000000 

__idata (IDATA address) + 0xF1000000 

__xdata (XDATA address) + 0xF2000000 

Table 4-1 Access Memory Space with Offset 

For example, to access the 0x10 location of __xdata memory, user need to fill 0xF2000010 into the 
Memory Browser or Memory View. Refer to Figure 4-46. 
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Figure 4-46 Access Memory Space with Memory Browser 

 

Figure 4-47 Access Memory Space with Memory View 

To monitor the variable value, user can observe the variable through the Watch Expressions View and 
add the specified offset address to access the variable value in different memory space. 
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Figure 4-48 Access Variable with Watch Expressions View 

4.11.4 Use OpenOCD Command to Program Flash 

After completing the installation of the NuEclipse installer, locate the OpenOCD folder in the installation 
path. Open a terminal and change to the OpenOCD/bin folder. Enter the following command: 

./openocd_8051_1T -f ../scripts/interface/nulink.cfg -f ../scripts/target/numicro8051_1T.cfg 

Then, open another terminal and enter the following command: 

telnet localhost 4444 

After successfully connecting, enter the following command, 0 is the starting position for flashing: 

flash write_image erase Test.bin 0 

 



NuEclipse 

Jun. 14, 2024 Page 57 of 62 Rev 1.02.027 

N
U

E
C

L
IP

S
E

 U
S

E
R

 M
A

N
U

A
L

 

5 Q&A 

1. Q: Can we simultaneously debug on Eclipse, Keil and Iar? 

A: No, we must stop the debug mode on Eclipse first. Then we can debug on another IDE. 

2. Q: Can we simultaneously debug on Eclipse and use the Nuvoton development tools, such as 
ICP Programming tool? 

A: No, we must stop the debug mode on Eclipse first. Then we can use them and vice versa. 

3. Q: How many breakpoints and watchpoints are supported? 

A: It depends on the hardware. For M0 chips, the supported number of breakpoints and 
watchpoints is 4 and 2, respectively. For M4 chips, the supported number of breakpoints and 
watchpoints is 6 and 4, respectively. For M23 chips, the supported number of breakpoints and 
watchpoints is 4 and 4, respectively. For 8051 1T chips, the supported number of breakpoints 
is 8. For now, we do not support flash breakpoints. 

4. Q: How to update firmware for Nu-Link? 

A: Please use ICP Programming tool or Keil to update firmware. 

5. Q: How to change Flash and RAM size after projects are created? 

A: Please find and open the ld script in the ld scripts folder. From there, we can change Flash 
and RAM size. 

6. Q: Why can the application not enter the debug mode? 

A: Firstly, we must install all the stuff by following the previously mentioned steps. Then check 
the following list: 

– Leave the previous debug mode first if exists. 

– Flash and RAM size must be correct. 

– OpenOCD should not be launched before debugging. To check that, please go 
to Windows Task Manager or System Monitor. If an OpenOCD process has 
already been running, please end the process. 

– The target chip should not be held by other tools or IDE. 

– The Config options field of the Debugger tab must be correct. 

– The GDB Client Setup Executable field of the Debugger tab must be correct. 

– In the Startup tab, the Initilal Reset type should be init. The Pre-run/Restart 
rest type should be init. 

– The Eclipse preferences must be correct. Please refer to the previous 
discussion. 

– Upgrade Nu-Link firmware and USB driver to the latest one. 

– Check whether the hex file is generated under the project successfully. 

– Check whether the executable has been downloaded to the target chip correctly. 

– Check SP. If it is wrong, please assign it to the correct location. 

– Write a correct Config value into the target chip. 

– If the operating system is Windows 7, please use USB 2.0 port, instead of USB 
3.0 port. 

– The project path must not contain any special character or whitespace, such as 
#$&`.{}. 

– Restart the computer.  
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7. Q: How to add udev rules for Nu-Link on GNU/Linux? 

A: When accessing target chips via Nu-Link, GNU/Linux requires the USB permission. We can 
get the permission by adding udev rules for Nu-Link. Here are the steps to do that: 

– Add the User to the plugdev Group. Type the command in the Terminal:  

sudo useradd -G plugdev $USER 

– Add Nu-Link to udev. Type the commands in the Terminal: 

cd /etc/udev/rules.d and sudo gedit 10-openocd-nulink.rules 

– Add the following text to the file 

 

Figure 5-1 Adding Udev Rules 

– Reloaded the new udev rules by entering the command in the Terminal: 

sudo udevadm trigger 
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8. Q: How to edit string substitution for openocd_nulink_path? 

A: The openocd_nulink_path string stores where the OpenOCD executable resides. After 
upgrading NuEclipse, the string may keep the previous OpenOCD path. To fix it, click Window 
> Preferences, the Preferences wizard appears. Go to Run/Debug > String Substituion. 
Find and edit the openocd_nulink_path to the new OpenOCD path. 

 

Figure 5-2 Preferences for String Substitution 
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9. Q: Why does Eclipse fail to update or install new software packs on Windows? 

A: One of possible reasons is that the write permission for Windows folders is denied. We 
need to find the correct folder and allow the write permission. On Windows, the location where 
we place software packs is C:\Program Files (x86)\Nuvoton Tools\Packages. 

10. Q: How to adjust output voltage of Nu-Link2? 

A: Upgrade the NuLink2 firmware greater than version v3.08.7249, open NU_CFG.TXT file in 
pop-up "NuMicro MCU" disk, you will see some options in NU_CFG.TXT. 

Set CMSIS-DAP=1 then re-plug in USB cable, it presents one more interface HID_CMSIS-
DAP, this is handy if you want to use CMSIS-DAP protocol. 

Set LEVEL=3 then re-plug in USB cable, it presents one of output voltage, this is handy if you 
want to use 5V voltage. 

 

Figure 5-3 More Options for NuLink2 

11. Q: Why GDB could not determine GDB version and launch failed on Linux of newer version? 

A: Create a soft link from the higher version to version 5 if libncurses5 is not installed or 
supported on system. Type the commands in the Terminal: 

– arm-none-eabi-gdb: error while loading shared libraries: libncurses.so.5: cannot 
open shared object file: No such file or directory. 

ln -s /usr/lib64/libncurses.so.6 /usr/lib64/libncurses.so.5 

ln -s /usr/lib64/libtinfo.so.6 /usr/lib64/libtinfo.so.5 

 



NuEclipse 

Jun. 14, 2024 Page 61 of 62 Rev 1.02.027 

N
U

E
C

L
IP

S
E

 U
S

E
R

 M
A

N
U

A
L

 

6 REVISION HISTORY 

Date Revision Description 

2017.03.31 0.01.000 Alpha version released. 

2017.06.30 1.01.000 Beta version released. 

2018.09.15 1.01.013 Official version released. 

2018.11.30 1.01.014 
1. Supported NUC505. 

2. Updated the new project wizard. 

2019.08.09 1.01.015 Supported M031 ,M261 and M480LD. 

2020.03.06 1.01.016 Supported M031BT, NUC1311, M2354  and M479. 

2020.09.30 1.01.017 Supported M030G, M071, M0A21, M251 and M471. 

2021.03.12 1.01.018 Supported M030GM031G and NUC1262. 

 
2021.12.01 1.01.019 Supported M460, I94100 and KM1M7. 

2022.04.25 1.02.019 Supported MA35D1. 

2023.02.07 1.02.022 Supported 8051 1T. 

2023.05.26 1.02.023 Supported M2L31. 

2024.01.31 1.02.025 Supported M2003, M433 and M55M1. 

2024.06.14 1.02.027 Supported M2A23, KM1M0D. 
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Important Notice 

Nuvoton Products are neither intended nor warranted for usage in systems or equipment, any 
malfunction or failure of which may cause loss of human life, bodily injury or severe property 
damage. Such applications are deemed, “Insecure Usage”.  

Insecure usage includes, but is not limited to: equipment for surgical implementation, atomic 
energy control instruments, airplane or spaceship instruments, the control or operation of 
dynamic, brake or safety systems designed for vehicular use, traffic signal instruments, all types 
of safety devices, and other applications intended to support or sustain life.   

All Insecure Usage shall be made at customer’s risk, and in the event that third parties lay claims 
to Nuvoton as a result of customer’s Insecure Usage, customer shall indemnify the damages and 
liabilities thus incurred by Nuvoton. 
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